-
Type: Task
-
Status: Open
-
Priority: Minor
-
Resolution: Unresolved
-
Affects Version/s: 62
-
Fix Version/s: QualifiedToSchedule
-
Component/s: Technical / Transverse
-
Tags:
-
Story Points:1
In Git, HEAD has a special meaning, it is a reference to the last commit in the currently checked-out branch.
When using an API called head, I would expect to have a Git commit as return type. Currently, the StudioService#getHead() returns a RevDiff, which is more like the difference between HEAD and its parent(s) HEAD^. If the returned object RevDiff is the desired result on the client side, then we should rename the method to another name, like getDiff(String, String), where the method accept 2 arguments, the 2 commits SHA-1 for the comparison. When handling this issue, we should also check the VCS endpoint for Web UI and the impact on the client side (maybe Web UI & Nuxeo Connect Client)
- is related to
-
NXS-3940 Create Studio endpoints to display Git info
- Resolved