Uploaded image for project: 'Nuxeo Platform'
  1. Nuxeo Platform
  2. NXP-14406

MANIFEST.MF Bundle-Version must state a correct and relevant version/revision

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Reopened
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: 11.1
    • Tags:
    • Upgrade notes:
      Hide

      Remove buildnumber-maven-plugin
      Install git-commit-id-plugin v2.2.6
      Upgrade maven-ejb-plugin to 3.0.1
      Upgrade maven-jar-plugin 3.1.1

      Show
      Remove buildnumber-maven-plugin Install git-commit-id-plugin v2.2.6 Upgrade maven-ejb-plugin to 3.0.1 Upgrade maven-jar-plugin 3.1.1
    • Sprint:
      DevOps-25, DevTools-04, DevTools-05, DevTools-06, DevTools-10
    • Story Points:
      2

      Description

      In the JAR bundle, the MANIFEST.MF "Bundle-Version" is currently set to useless and irrelevant values.
      It must match the JAR version. Including the SCM revision is also (even more) wanted.

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                4 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:

                  Time Tracking

                  Estimated:
                  Original Estimate - 2 hours
                  2h
                  Remaining:
                  Remaining Estimate - 2 hours
                  2h
                  Logged:
                  Time Spent - Not Specified
                  Not Specified

                    PagerDuty

                    Error rendering 'com.pagerduty.jira-server-plugin:PagerDuty'. Please contact your Jira administrators.