Uploaded image for project: 'Nuxeo Platform'
  1. Nuxeo Platform
  2. NXP-12081

Allow wildcards in target platforms for Marketplace packages

    XMLWordPrintable

    Details

    • Backlog priority:
      500

      Description

      We need to install a package built for an official release on a maintenance build without relaxing the target platform constraint.
      For instance: a package built for 5.6.0 must be installable on a 5.6.0-HF08. Even if 5.6.0-HF08 is not an official release (it's a manual build from the maintenance branch or a download of a "hotfixed" distribution), some developers/customers sometimes use such distributions. Using the "relax" option is an issue since it brings install of 5.7* packages (in that sample case).

      A clean solution would be to explicitly state in the Marketplace package that they are compliant with "5.6.0" and "5.6.0-HF*".
      Another solution would be to hard-code that "HF*" compliance in the platform
      Going on the clean solution, the required changes and drawbacks are:

      • add wildcards management in the platform,
      • ability to install hotfix packages (ie: 5.6.0-HF01 on a 5.6.0-HF08 distribution!) but the install would have no effect on the distribution,
      • packages must be updated to add the generic HF* target (not a big deal using the Connect UI or API).

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - 4 hours
                  4h
                  Remaining:
                  Remaining Estimate - 4 hours
                  4h
                  Logged:
                  Time Spent - Not Specified
                  Not Specified

                    PagerDuty

                    Error rendering 'com.pagerduty.jira-server-plugin:PagerDuty'. Please contact your Jira administrators.