Uploaded image for project: 'Nuxeo Elements'
  1. Nuxeo Elements
  2. ELEMENTS-895

Video player does not work in Safari (Web UI)

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 2.2.0, 2.4.0, 3.0.0
    • Fix Version/s: 2.2.29, 2.4.3, 3.0.0
    • Component/s: Viewers

      Description

      1. install nuxeo
      2. install DAM addon
      3. install WEB UI addon
      4. login with Chrome
      5. create a workspace
      6. create a Video document
      7. attache a video
      8. wait for the processing to complete (check ffmpeg is not running any longer)
      9. refresh the document
      10. try to read the video through the player
      11. observe it works
      12. try the preview
      13. try to read the video through the player
      14. observe it works
      15. now try both reads using Safari it fails (see attached screenshots)

      Expected behavior: the preview should work in Safari as it does in Chrome.
      Note: this does not happen in 8.10 and works fine.
      Note 2: this also happens in JSF (see NXP-26982)

        Attachments

        1. safariInactivePlayer.png
          safariInactivePlayer.png
          591 kB
        2. safariInactivePlayer2.png
          safariInactivePlayer2.png
          595 kB
        3. safariInactivePlayer3.png
          safariInactivePlayer3.png
          749 kB
        4. safariInactivePlayer4.png
          safariInactivePlayer4.png
          753 kB
        5. videoReady.png
          videoReady.png
          234 kB

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  PagerDuty