Uploaded image for project: 'Nuxeo Studio'
  1. Nuxeo Studio
  2. NXS-4353

Do not add a dependency on nuxeo-jsf-ui for packages with tp <8.10

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 73.0.1
    • Fix Version/s: 73.0.2, 73.1
    • Component/s: Packaging

      Description

      The package built against versions

      • 6.0
      • 7.10
      • and more generally any version < 8.10

      contains a dependency on nuxeo-jsf-ui whereas this package does not exist for this version.

      This is a critical issue because the installation of the package relaxes all constraints and therefore you can end with packages compatible with Nuxeo 9.3 on your 7.10 installation.

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                1 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0 minutes
                  0m
                  Logged:
                  Time Spent - 3 hours
                  3h

                    PagerDuty

                    Error rendering 'com.pagerduty.jira-server-plugin:PagerDuty'. Please contact your Jira administrators.