Uploaded image for project: 'Nuxeo Platform'
  1. Nuxeo Platform
  2. NXP-30653

Upgrade various dependencies

    Details

    • Release Notes Summary:
      The upgrade of Apache PDFBox from 1.8.16 to 2.0.24 introduces breaking changes to the library, code relying on it must be updated.
    • Upgrade notes:
      Hide

      The upgrade of Apache PDFBox from 1.8.16 to 2.0.24 introduces breaking changes to the library, code relying on it must be updated.

      See the Migration to PDFBox 2.0.0 guide.

      Show
      The upgrade of Apache PDFBox from 1.8.16 to 2.0.24 introduces breaking changes to the library, code relying on it must be updated. See the Migration to PDFBox 2.0.0 guide.
    • Team:
      PLATFORM
    • Sprint:
      nxplatform #46, nxplatform #47

      Description

      Upgraded dependencies:

      • org.apache.santuario:xmlsec 2.1.4 -> 2.1.7
      • org.apache.commons:commons-compress 1.19 -> 1.21
      • net.minidev:json-smart 1.1.1 -> 1.3.2
      • org.yaml:snakeyaml 1.21 -> 1.26
      • org.apache.ant:ant 1.7.0 -> 1.9.16
      • org.quartz-scheduler:quartz 2.3.0 -> 2.3.2
      • com.fasterxml.jackson.core:jackson-databind 2.9.10 -> 2.9.10.7
      • com.ibm.icu:icu4j 62.1 -> 63.2
      • org.codehaus.plexus:plexus-utils 1.5.6 -> 1.5.15
      • com.thoughtworks.xstream:xstream 1.4.11 -> 1.4.18
      • org.apache.avro:avro 1.8.2 -> 1.9.2
      • org.apache.pdfbox:pdfbox 1.8.16 -> 2.0.24

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  PagerDuty

                  Error rendering 'com.pagerduty.jira-server-plugin:PagerDuty'. Please contact your Jira administrators.