Uploaded image for project: 'Nuxeo Platform'
  1. Nuxeo Platform
  2. NXP-30140

Upgrade Keycloak library

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 11.5
    • Component/s: Authentication
    • Tags:
    • Team:
      FG
    • Sprint:
      nxFG 11.3.1
    • Story Points:
      3

      Description

      We're using 4.6.0.Final, which is old. Upgrade to 12.0.2.

      This will also be required to move to Java 15, as we'll need a recent version (and even 12.0.2 doesn't yet support even Java 14, see https://github.com/keycloak/keycloak/pull/7720 and https://issues.redhat.com/browse/KEYCLOAK-13633).

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0 minutes
                0m
                Logged:
                Time Spent - 4 hours
                4h

                  PagerDuty

                  Error rendering 'com.pagerduty.jira-server-plugin:PagerDuty'. Please contact your Jira administrators.