Uploaded image for project: 'Nuxeo Platform'
  1. Nuxeo Platform
  2. NXP-28437

S3 probe should not report failure when there are not S3 blob providers

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 10.10
    • Fix Version/s: 10.10-HF20, 11.1
    • Component/s: BlobManager, S3
    • Release Notes Summary:
      S3 probe returns a success when no S3 blob provider is configured.
    • Sprint:
      nxFG 11.1.11
    • Story Points:
      1

      Description

      Since NXP-26180 the S3 probe returns failure when the S3 code is present but not S3 blob providers are configured. Therefore the global probe (that collects the results of all probes) also fails.

      This is wrong because the presence of the classes should not influence the result of the probes, only the presence of the configuration.

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0 minutes
                  0m
                  Logged:
                  Time Spent - 1 hour
                  1h

                    PagerDuty

                    Error rendering 'com.pagerduty.jira-server-plugin:PagerDuty'. Please contact your Jira administrators.