There is already:
but it is based on ordered parameter and it is actually more designed for JSF UI because:
We'd like a new user_collections page provider (more explicit name) with explicit named parameters that we can use in a nuxeo page provider element.
It would be much readable and maintainable.
Finally, the new web ui also shows the Favorites in the Collections section of the left-hand side drawer. But there's already a section dedicated for Favorites. No need to show it again. The new page provider should also exclude favorites.