Current the JIRA REST API is partly implemented in jira.sh:
But on top of the official API, some custom functions to deal with Nuxeo-specific use cases have been added.
Ideally the JIRA REST API should be in jira.sh and additional functions in jira_misc.sh.
The following functions should be in jira_misc.sh:
At the same type of the split, some cleanup could be done like:
- follow Shell function naming conventions and update the scripts using those
- replace the last occurence of json_pp with jq .
- add Nuxeo headers to both libs