Uploaded image for project: 'Nuxeo Elements'
  1. Nuxeo Elements
  2. ELEMENTS-896

row detail cannot be displayed

    XMLWordPrintable

    Details

      Description

      1. using the following code in a project, the row details cannot be displayed (see noRowDetails.png):
            <nuxeo-data-table id="table" nx-provider="bookPP"
                              details-enabled>
              <template is="row-detail">
                <div class="detail">
                  <p>ozicopaizjepoiajzpeoirjpazoiejr</p>
                  <p>aze</p>
                  <p>raz</p>
                </div>
              </template>
              <nuxeo-data-table-column name="[[i18n('book.title')]]" flex="100" filter-by="dublincore_title" sort-by="dublincore_title" >
                <template is="header">
                    header1
                </template>
                <template>
                  <nuxeo-document-thumbnail document="[[item]]"></nuxeo-document-thumbnail>
                  <a class="title ellipsis">[[item.title]]</a>
                </template>
              </nuxeo-data-table-column>
              <nuxeo-data-table-column name="[[i18n('book.publicationDate')]]" flex="100" filter-by="book:publicationDate" sort-by="book:publicationDate">
                <template is="header">
                    header2
                </template>
                <template>
                  <nuxeo-date datetime="[[item.properties.book:publicationDate]]"></nuxeo-date>
                </template>
              </nuxeo-data-table-column>
            </nuxeo-data-table>
        

      Expected behavior: the row details should be displayed.
      Debugging session results: it seems the following line is never true
      https://github.com/nuxeo/nuxeo-ui-elements/blob/maintenance-2.2.x/nuxeo-data-table/iron-data-table.html#L720
      even if the template is present (see code in the description)
      The rowDetail property seems to be set here:
      https://github.com/nuxeo/nuxeo-ui-elements/blob/maintenance-2.2.x/nuxeo-data-table/iron-data-table.html#L516
      But when doing debugging in getContentChildren, the template is never found (see screenshot rowDetailNotFound.png).

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:

                PagerDuty